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Introduction 

 
 The PBGUNS Input GUI program is a graphical application for generating an 
input file for the PBGUNS program. PBGUNS is useful for solving a wide range of DC 
electron and ion source problems, and is described in the manual: “PBGUNS Manual, 
version 5.2”.  
 
 In this version of the PBGUNS Input GUI, we have added better descriptions for 
the variable names that appear in the input file; the old names are now shown in 
parentheses for users that are expert in interacting directly with the PBGUNS application. 
 
 Another feature we are happy to announce is the ability to import the problem 
geometry from a CAD application via the STEP format. This is further described in the 
section on CAD import in this manual. 

 
 

Installation 
 

 Double-click “vcredist_x86.exe”.  This installs all Visual C++ libraries as shared 
assemblies on your computer.  (For Windows XP Home Edition, Windows XP 
Professional, Windows Server 2003, and Windows Vista, the libraries are installed in the 
WinSxS folder.   For all other versions of Windows, the libraries are installed in both the 
WinSxS and System32 folders.)  The Input GUI is now ready to run.  Note that it must 
always have access to the Qt dll’s included with the distribution.     

 
 

How to Use the Input GUI 
 

Double-click “pbgunsInput.exe” to launch the PBGUNS Input GUI.  When the 
GUI opens, enter your input parameters as described in the next section.  After you are 
done, save the file.  Then open the regular PBGUNS program and select the "pick from 
available data files" option to use the new input file. 
 
 

Entering/Editing PBGUNS Input Parameters 
 
 The PBGUNS input variables are listed on the five tabs: MODEL/CONTROL, 
GEOMETRY, MESH, PHYSICS, and POST-PROCESSING.  Default values are given 
when the program is first opened, but please note that the default values do not constitute 
a valid input set.   



 
Descriptive names are listed next to most of the default values, with the original 

PBGUNS Fortran variable names given in parentheses.  (Some fields only have the 
original PBGUNS variable names.)  To get a brief description of a variable, let the mouse 
hover over it.  To see a more detailed description, click on it.  The description will appear 
in the left pane.  This left pane acts like a browser.  Any other variable mentioned in the 
text is a clickable link.  To move backward or forward through the links, click on the 
green “Backward” or “Forward” arrow in the toolbar (or, alternatively, select View-
>Back or View->Forward).  To zoom in or out, click on the appropriate magnifying glass 
in the toolbar (or select View->Zoom in or View->Zoom out).     

   
 Some of the variables are linked to others.  For instance, if you select ICT = 2 (on 
the MODEL/CONTROL tab), the default parameters (linked to ICT = 1) will be removed 
from the GUI, since they are no longer relevant.  If you then set ICT = 12, a new set of 
parameters (linked to ICT = 12) will appear.   
 
 One such set of linked parameters occurs when IBMAG = 1 or IBMAG = 4 (on 
the Physics Tab).  In a PBGUNS input file (.DAT), this causes Line 23 to be read in 
(which is automatically transferred to a default, temporary file used by the GUI, 
“bfile.txt”).  You will notice that in the GUI, setting IBMAG equal to one or four causes 
a filename field (FILE = bfile.txt) to appear.  If you are entering new data from another 
file other than bfile.txt, the name of the file containing the Line 23 values should be 
entered in the FILE field.  (See the description in the GUI for formatting requirements.)  
Please note that the filename “bfile.txt” is reserved.  Use this filename with caution; any 
values in it will be over-written when a file with Line 23 values is opened; furthermore, 
this file will be deleted when the GUI window gets closed. 
 
 To enter a geometry, switch to the GEOMETRY tab.  Specify the desired number 
of electrodes.  Then, for each electrode, specify the desired number of line segments 
(NK), the voltage (VLT), and whether the electrode crosses the fine matrix boundary 
(NEX).  (You may need to read the input into PBGUNS to determine the position of the 
fine matrix relative to the electrodes.)  Changing the number of segments (NK) will cause 
another table to appear; each row in this table corresponds to one line segment for that 
electrode.  Select the line segment type from the pull-down menu.  This may cause some 
boxes to be greyed out; input should not and cannot be given in any box which is greyed 
out.   
 
 When you select a line segment type, the browser displays a description of the 
parameters which are available for that segment type.  The numbers correspond to 
columns in the table.  The data in this table is in scaled units.  To add or remove rows 
from anywhere in the table, right click on one of the input boxes and select “Insert Row 
Below”, “Insert Row Above”, or “Delete Row”.    
 
 Once you have input your geometry, you have the ability to move electrodes 
easily.  To do this, right-click in a table where an electrode geometry is specified, and 
select the menu option for “Move electrode”.  This pops up a dialog to specify how far to 



move the electrode in the r and z directions.  The units are the same as in the electrode 
geometry tables (“scaled units”).  You can move all electrodes the same distance by 
checking the “Move all electrodes this distance” box.  If the electrode touches the edge of 
the domain, the points that touch the edge will not be moved.  If the r or z values would 
put any endpoints of electrode line segments outside the domain, an error message 
appears and the geometry is reset back to its previous location.  Note: only the endpoints 
of each line segment are tested.  It is still possible that a curving line segment could go 
outside the domain.  The user is responsible for preventing this.     
 
 To reset the GUI to the default input values, select File->New (or click on the 
blank document in the toolbar).  To load an existing .DAT input file into the GUI, go to 
File->Open (or click on the folder in the toolbar).  To save the current values, select File-
>Save As and select a file name.   After opening or saving a file, the file name will be 
displayed at the top of the GUI.  This file name specifies where the current values are 
saved if you select File->Save (or click on the floppy disk in the toolbar).       
 
 You also have the option of opening a recent file directly from the File menu.  
The four most recently used files are listed near the bottom of the menu, for your 
convenience.  Please note that the filename “recentlyUsedFiles.txt” is also reserved.  
Editing or deleting this file may cause the recent files to be displayed incorrectly.   

   
 

CAD Import 
 

 
 The PBGUNS Input GUI can now import a specially prepared solid model file in 
STEP AP203 format generated with an external CAD program. Although the STEP 
format describes a solid 3-D geometry, the import function examines surfaces only 

Figure 1: Setup of a CAD model for export/import into the 
PBGUNS Input GUI. 



located on the X-Z plane and ignores the rest of the 3-D model. Many CAD programs can 
be used to export to STEP format, including SolidWorks, Solid Edge, Autodesk Inventor, 
and Autodesk Fusion 360, etc. 
 
 In order to generate the problem geometry for import into the PBGUNS Input 
GUI, one should first make a 3-D solid model of the device, as shown in Figure 1. Note 
that the 2-D problem geometry exists in the X-Z plane and the part surface that will be 
used for the 2-D import is visible from the positive Y direction. The geometry must also 
conform to expected PBGUNS form, such as having a well-defined bounding box 
starting at x=0, z=0, and for the feature sizes to be well-resolved on the PBGUNS mesh. 
Figure 1 shows a solid model generated by sweeping the initial surface through 90 
degrees, but in principle an extruded model can also be used. 
 
 Since PBGUNS uses square grid cells to model the problem, the total problem 
extent in each direction ought to be an integer number of grid points. A good strategy to 
use at the stage of generating the CAD model is to decide on the problem aspect ratio, 
such as 2:1, or 5:3, etc. of longitudinal to transverse extent, and make sure to have the 
active number of radial points (NR-1) and longitudinal (NZ-1) number of points conform 
to the same ratio. For example a 3:4 ratio can be achieved with NR = 151 and NZ = 201. 
During the CAD input process, one does not have to input the new NZ and DZ, but only 
NR and ZSCALE, and the import procedure will determine the NZ and DZ values. 
 
 The CAD import procedure currently has the following limitations, and will 
report errors if any problems are detected. 

• The format must be AP203 and not AP214. 
• Only linear and circular arc segments are allowed. B-spline and rational B-

splines, and therefore ellipses and parabolas are flagged as errors. 
• The geometry must not have a radial offset as specified by the NR0 parameter, or 

be a cartesian (X-Y) geometry specified by NR0=9999. 
 

 A CAD import is performed by using the “Import...” menu item and selecting an 
import file. After the import, one ought to view the geometry to make sure that the 
number of conductors and identification of the first conductor are correct. Upon initial 
import, all previously defined conductor potentials are set to zero. The import function 
does not work with the Undo function, so it is not possible to Undo the changes brought 
about by an Import... procedure. 
 

The procedure to import a model is then: 
     1) Set the desired NR and ZSCALE parameters, and make sure NR0=0. 
     2) Import the STEP file and visually check the geometry. 
     3) Set the new conductor parameters: VLT, NEX, CX, RSTRT, ZSTRT, REND,  
         ZEND. 
     4) Finish setting up the problem and attempt to run the model. 
 
 
 



Using the Geometry Display 
 

You can view the geometry by selecting View->Geometry or by clicking on the 
Geometry icon in the toolbar. This will pop up a separate window which displays the current 
geometry. This option will not function properly unless you have already specified NZ, NR, 
NR0, and DZ on the MESH tab.  

 
Each electrode will be plotted in a different color; the colors start to cycle after seven 

electrodes. The bounding box is displayed in black. All electrodes listed in the PBGUNS 
Input GUI tables must be in counterclockwise order; otherwise, the electrodes will not be 
shaded as expected. You can view the electrode numbers, global line numbers (“Show 
PBGUNS line numbers”), or line numbers within each electrode (“Show GUI line numbers”) 
by right-clicking anywhere in the drawing area and selecting the appropriate option from the 
list. To return to the Input GUI, you must close the Geometry window.  

 
 

The Geometry Display 
 

When the geometrical objects are loaded from the PBGUNS Input GUI, they will be 
displayed centered and appropriately sized for the Geometry Display. If the PBGUNS Input 
GUI geometry tables contain any errors, you will be notified of the error, and the line 
containing the error will be skipped.  

 
Within the Geometry Display, the z-axis is represented by a gray horizontal line, 

while the r-axis is a gray vertical line. The axes labels are shown in physical dimensions. As 
you move the mouse around within the Geometry Display, the current physical coordinates 
will be displayed in the lower left corner of the GUI. If at any time you find that your 
drawing is no longer fully visible on the screen, pressing the Escape key will cause the 
geometrical objects to be re-centered and appropriately sized for the Geometry Display 
window.  

 
Pan and Zoom 

 
The Geometry Display also provides panning and zooming capabilities. These 

buttons can be found in the toolbar, at the far left. Once a plot interaction button is pressed 
down, it remains active until another button is selected.  

 
Select mode (entered by clicking on the arrow icon) is the default mode. While in 

select mode, you have the ability to view the coordinates as you move the mouse (without the 
possibility of accidentally clicking somewhere and changing the view) .  

 
In pan mode (the hand icon), you can move your drawing in any direction by the 

standard click-and-drag method. The arrow keys can also be used for scrolling.  
 
In zoom in mode (the + icon), a single-click anywhere within the viewing window 

will cause the Geometry Display to zoom in on that location. In zoom out mode (the  
– icon), a single-click will shrink the drawing, centering it on the location where you clicked.  
 



 
Invalid Geometry Detection 

 
You can use the Geometry Display to verify that your geometry is valid. A “valid” 

geometry is one which is watertight (all electrodes are closed and are either self-contained or 
start and end on a domain boundary). The user is responsible for verifying any other aspects 
of a valid geometry (such as intersecting electrodes). If your geometry is not valid, the 
simulation will not run in PBGUNS. To check for validity, click on the “Verify Geometry” 
icon (the red flag at the right end of the toolbar). If the geometry is valid, you will be notified. 
If it is not valid, yellow error circles are placed at any line segment endpoints which do not 
connect to another line segment or the outer boundary. This makes it easy to spot where the 
geometry needs to be fixed. (To remove the error circles, simply click somewhere inside the 
Geometry Display.)  

 
 

Saving and Printing 
 

To save or print the figure, right-click anywhere in the drawing area and select the 
desired option from the menu. All figures are saved in PNG format.  

 
 

Table of Geometry Display Actions 
 

Desired Action  Mode  Keyboard/mouse Action(s)  
pan  pan  click and drag in desired direction 
zoom in  zoom in  single-click on desired center point  
zoom out  zoom out  single-click on desired center point  
scale drawing to screen  any  hit Escape  
view electrode numbers  any  right-click and select from menu  
view line numbers  any  right-click and select from menu  
save/print image  any  right-click and select from menu  
verify geometry  any  click on red flag toolbar icon  

 
 
 
 
 
 
 
 



Appendix A: Tables of Input Variables 
 

The following table gives the location of the input variables within the Input GUI.  
The Line # is the line number within the PBGUNS input data file, as described in the 
PBGUNS User’s Manual.  In the second column, variables associated with that line are 
listed.  The Tab column shows where these variables are located in the GUI.    

 
Line # Variables Tab 
1 MM, KKM MODEL/CONTROL 
1 NZ, NR, NR0, INF MESH 
1 ICAT GEOMETRY 
1 IBMAG PHYSICS 
1 IDG, NFZ, NFR, NZ0F, NR0F, 

ITP, IPD, IDIS, IOVL, IGRF 
POST-PROCESSING 

2 MU, ISP, ITD, IEQ POST-PROCESSING 
2 INEG, NOREL, IENJ, IRST, 

NION 
PHYSICS 

2 IXP, ISCS, IRF, NRLO, NRHI, 
NZLO, NZHI, INCR 

MODEL/CONTROL 

2 IRTD, RATD MESH 
3 SZERO, AMASS, E0, BMAG PHYSICS 
3 VSCALE, EPSV MODEL/CONTROL 
3 ZSCALE, DZ MESH 
4 BETA MODEL/CONTROL 
4 DTGT, CEN, EEL POST-PROCESSING 
4 STLIM, ZINE, ZITC, BENU, 

ECAT, EINT 
PHYSICS 

5 ZEP(1-4) POST-PROCESSING 
5 ZSAV, ZTARG MESH 
5 ZSKP(1-4) MODEL/CONTROL 
6 all variables PHYSICS 
7 NK, VLT, NEX(1)  GEOMETRY 
7 ICT MODEL/CONTROL 
7 RSTRT, ZSTRT, REND, ZEND MESH 
7 SLITLN PHYSICS 
7 ZNEP, NROFF, NZOFF, NMAX POST-PROCESSING 
8a all variables MODEL/CONTROL 
8b all variables MODEL/CONTROL 
9(a-b) all variables MODEL/CONTROL 
10-12 all variables PHYSICS 
13-15 all variables MODEL/CONTROL 
16,16a all variables MODEL/CONTROL 
17 (& 20) all variables GEOMETRY 
18 (& 21) all variables GEOMETRY 
19 all variables GEOMETRY 



22 all variables MODEL/CONTROL 
23 all variables (read from a file) PHYSICS 
24a all variables PHYSICS 
24(b-c) all variables PHYSICS 
25 all variables not displayed 
26 all variables POST-PROCESSING 

 
 
There are a few things to note regarding the variables and their presence in the 

GUI:  1) NAN (Line 1) is no longer used, so it is not included in the GUI.  2) When 
applicable, CSV (Line 25) is read in from the .DAT file and saved back to the .DAT file, 
but it is not displayed in the GUI. 

 
The following table lists the lines associated with linked variables.  If the 

conditions in the “When it is Read” column are met, then the GUI will display the 
corresponding “Line #” variables.  Note: Line 2 is always read in, but the INCR variable 
in Line 2 is only read when Line 7: ICT = 6. 

 
Line # When it is Read 
6 Line 2: IENJ > 0 
8a Line 7: ICT = 1 
8b Line 7: ICT = 5 or Line 2: ISCS = 2 
9(a-b) Line 7: 10 < ICT < 17 
10-12 Line 7: ICT = 8 or ICT = 9 or ICT > 10  

AND  
Line 2: NION > 1 and Line 2: IRST = 0 

13-15 Line 7: 10 < ICT < 17 and Line 9a: ITBP > 1 
OR 
Line 7: ICT = 8, 9, or 18 and Line 7: NROFF > 1 

16,16a Line 7: 10 < ICT < 17 and Line 9a: ITBPS > 0 
23 Line 1: IBMAG = 1 or 4 
24a-c Line 1: IBMAG = 6 or 7 
25 not displayed 
26 Line 2: IEQ = 2 

 
 
 
 


